Inbound/Outbound Call Failures
Incident Report for CallTower
Resolved
As of 10:00AM MT, the workaround has been applied to all SIP trunks, including all UCaaS and contact center platforms, and all users should be working normally. Customers are reporting services have normalized and CallTower Support will continue to monitor closely. We are closing out this case.

A bug was discovered in our SIP trunking platform that caused the system to reject inbound and outbound calls on some SIP trunks. CallTower is continuing to work with the vendor on the permanent resolution. As additional information is provided by the vendor on a permanent resolution, CallTower will implement those changes.

If you continue to experience issues, please contact CallTower Support at support@calltower.com.
Posted Feb 24, 2020 - 10:28 MST
Monitoring
CallTower Engineers are continuing to apply the workaround to the affected CT Cloud SIP customers. Bulk updates are currently being applied to the affected SIP trunks. The estimated time to completion of the remaining trunks is 10:00 AM MT. As the updates are applied, customers are reporting that services have normalized.

Please contact CallTower Support if you are affected by this issue at support@calltower.com or 1-800-347-5444.
Posted Feb 24, 2020 - 09:36 MST
Update
CallTower has applied a work around on all internal trunks which has stabilized the Cisco, Microsoft and contact center platforms. CallTower Engineers are in the process of applying the workaround to the affected CT Cloud SIP customers now.
Posted Feb 24, 2020 - 08:43 MST
Identified
CallTower has identified an issue with inbound and outbound call failures on some SIP trunks. A workaround is being implemented on specific SIP trunks and specific calling platforms to correct this issue. CallTower engineers have engaged our vendor with a Priority 1 case. Please contact CallTower Support if you are affected by this issue at support@calltower.com or 1-800-347-5444.
Posted Feb 24, 2020 - 07:56 MST
This incident affected: CT Cloud (CT Cloud SIP).