CT Cloud SIP Outbound Calls Ringing Fast Busy
Incident Report for CallTower
Resolved
The issue with CT Cloud SIP outbound calls ringing fast busy is considered resolved and all associated cases will be closed out.

CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request.
Posted Apr 24, 2024 - 10:41 MDT
Update
CallTower Engineering and Support continue to monitor the issue. CallTower Support continues to not receive any further reports of the issue.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com tomorrow early morning, unless identified otherwise.
Posted Apr 23, 2024 - 16:57 MDT
Update
CallTower Engineering and Support continue to monitor the issue. CallTower Support continues to not receive any further reports of the issue.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 60 minutes, unless identified otherwise.
Posted Apr 23, 2024 - 14:52 MDT
Update
CallTower Engineering and Support continue to monitor the issue. CallTower Support has not had any new or further reports of the issue.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 60 minutes, unless identified otherwise.
Posted Apr 23, 2024 - 13:42 MDT
Monitoring
CallTower Engineering has taken steps to mitigate the issue. Several CallTower customers have confirmed the issue to be resolved. CallTower will continue to monitor the issue.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Apr 23, 2024 - 12:52 MDT
Investigating
CallTower support is investigating multiple reports of CT Cloud SIP customer reporting outbound calls ringing fast busy but has not identified/confirmed there is an issue on our network or with our services.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Apr 23, 2024 - 12:08 MDT
This incident affected: CT Cloud (CT Cloud SIP).