Inbound Calls Dropping
Incident Report for CallTower
Resolved
CallTower Engineers have finished implementing a workaround and are seeing services normalize. Customers are reporting the issue has been resolved. Please report any ongoing issues to CallTower by emailing support@calltower.com.
Posted Jul 17, 2020 - 09:59 MDT
Identified
CallTower Engineers have identified the point of failure for the issue and are actively implementing a workaround for affected customers. Customers may be experiencing issues with call drops when being transferred by Teams Resource Accounts (Auto Attendants or Call Queues).

Please reach out to CallTower Support (support@calltower.com) if you are experiencing this issue.
Posted Jul 17, 2020 - 09:20 MDT
Investigating
CallTower is investigating reports of an issue that is causing incoming calls to drop for Teams Resource Accounts. CallTower Engineers are working to identify the issue.

Please reach out to CallTower Support (support@calltower.com) if you believe you are experiencing this issue.
Posted Jul 17, 2020 - 08:37 MDT
This incident affected: Microsoft Teams - Direct Routing.