Microsoft Login Issue
Incident Report for CallTower
Resolved
CallTower Support has seen services stabilize and users are now able to log in to the Teams Client. Please continue to contact CallTower Support (support@calltower.com or call 800-347-5444), if you have CallTower Direct Routing for Teams and need assistance with redirecting calls to an alternate number.

Microsoft has provided an update on the Microsoft Teams issue that prevents users from logging into the client on desktop or mobile: “Current status: We've deployed the new authentication certificate to mitigate impact. We're currently performing targeted component restarts across our infrastructure to ensure the fix is applied to all affected customer environments. Additionally, we're investigating reports of impact to other Teams features such as chat history visibility and Auto Attendant functionality that may arise as our fix propagates.”

CallTower will continue to work directly with Microsoft until the issue is fully resolved. Please note that Teams is a Microsoft hosted service and CallTower Direct Routing is limited to external calling functionality.
Posted Feb 03, 2020 - 11:02 MST
Monitoring
Please continue to contact support@calltower.com or call 800-347-5444 if you have CallTower Direct Routing for Teams and need assistance with redirecting calls to an alternate number.

Microsoft has provided an update on the Microsoft Teams issue that prevents users from logging into the client on desktop or mobile: “Current status: We've deployed the fix to roll out a new authentication certificate, which has completed. We're monitoring the service, however, affected users should start to see recovering in the next hour.”

CallTower will continue to work directly with Microsoft and will provide an update at or before 10:30 MST. Please note that Teams is a Microsoft hosted service and CallTower Direct Routing is limited to external calling functionality.
Posted Feb 03, 2020 - 09:35 MST
Identified
Microsoft has acknowledged an issue with Microsoft Teams that prevents users from logging into the client on desktop or mobile. Specific information regarding the issue can be found on the Microsoft 365 Status Twitter feed at https://twitter.com/MSFT365Status?ref_src=twsrc%5Egoogle%7Ctwcamp%5Eserp%7Ctwgr%5Eauthor. Per Microsoft incident #TM202916, the next update is expected at 9:30 MT. CallTower will continue to work directly with Microsoft and will provide an update at or before this time. Please note that Teams is a Microsoft hosted service and CallTower Direct Routing is limited to external calling functionality.

If you have CallTower Direct Routing for Teams, CallTower can help you redirect calls to an alternate number. Contact support@calltower.com or call 800-347-5444 for assistance.
Posted Feb 03, 2020 - 08:52 MST
This incident affected: Microsoft O365/Teams and Microsoft Teams - Direct Routing.