Issue Affecting CallTower Services
Incident Report for CallTower
Resolved
Microsoft has provided confirmation that this issue has been resolved:

User Impact: Users may be unable to access multiple Microsoft 365 services and features.

More info: Additional information regarding service specific health can be found below:
Dynamics 365: Recovering
SharePoint Online: Recovering
Microsoft Intune: Mitigated
Microsoft Teams: Mitigated
Skype: Mitigated
Exchange Online: Mitigated
OneDrive: Mitigated
Yammer: Mitigated
Power BI: Mitigated
Power Apps: Mitigated
OneNote: Mitigated
Microsoft Managed Desktop: Mitigated
Microsoft Streams: Mitigated

Current Status: We have confirmed that the underlying DNS outage has been mitigated. Currently we are validating the recovery of the downstream Microsoft 365 services listed above. We will be providing a preliminary root cause and additional details within 60 minutes.

Scope of Impact: This issue may impact any user attempting to access multiple Microsoft 365 services and features.



*CallTower will be closing this master case and all associated cases. If you are still experiencing problems, please contact CallTower Customer Support by emailing support@calltower.com.
Posted Apr 01, 2021 - 18:07 MDT
Update
Microsoft has updated their status page with the following:

Current Status: Microsoft rerouted traffic to our resilient DNS capabilities and are seeing improvement in service availability. We are continuing to see availability improvements, so some customers may begin seeing services recover. We are managing multiple workstreams to validate recovery and apply necessary mitigation steps to ensure complete network recovery.

Scope of Impact: This issue may impact any user attempting to access multiple Microsoft 365 services and features.

Next Update: Friday, April 2, 2021 by 12:00 AM UTC


*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Apr 01, 2021 - 17:28 MDT
Monitoring
Microsoft has provided the following update:

Microsoft rerouted traffic to our resilient DNS capabilities and are seeing improvement in service availability. We are continuing to investigate
the cause of the DNS issue. The next update will be provided in 60 minutes or as events warrant.

As services begin to recover, admins can access additional details about this event in the admin center under MO248163.

In addition, CallTower Engineers are seeing internal Microsoft services being restored. Reports are also coming in from affected customers that services have normalized.


*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Apr 01, 2021 - 16:55 MDT
Identified
Microsoft is reporting a potential DNS issue that is affecting multiple services. CallTower customers may be affected by this issue.

Microsoft has provided the following update:
Title: DNS issue affecting multiple Microsoft 365 and Azure services
User impact: Users may be unable to access multiple Microsoft 365 services and features.
Current status: We've identified a Domain Name System (DNS) issue and are working to mitigate impact.
More info: Reports indicate that impact is primarily to Microsoft Teams, though other Microsoft 365 and Azure services may be affected.

Additional affected services include but are not limited to: Dynamics 365, Microsoft Intune, Skype, SharePoint Online, OneDrive, Yammer,
Power BI and Power Apps.

*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Apr 01, 2021 - 16:31 MDT
This incident affected: CT Cloud (CT Cloud SIP, CT Cloud Voice), Cisco Unified Communications (Cisco Voice), Skype for Business (Skype for Business - Voice), Contact Center (Clarity Connect), and Microsoft 365, Microsoft Teams - Direct Routing.