CT Cloud Contact Center Issues with Calls to Agents

Incident Report for CallTower

Resolved

After positive tests from CallTower customers regarding the Intermedia agent call issue, the issue is considered resolved and the associated cases will be closed out.

CallTower will be closing this master case and all associated cases. CallTower will work on an Official Root Cause Analysis (RCA) with Intermedia and one will be provided to customers upon request.
Posted Jan 03, 2023 - 12:27 MST

Monitoring

Intermedia identified more than double the usual load on their Automatic Call Distribution servers. Intermedia's System administrators were able to increase capacity which mitigated the issue. CallTower will monitor the issue until confirmed fully resolved.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Jan 03, 2023 - 12:13 MST

Investigating

CT Cloud Contact Center (Intermedia) is experiencing issues with calls to agents. Intermedia's operations team is currently investigating and working to restore service as soon as possible. This is impacting Intermedia's Virginia Data Center only.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Jan 03, 2023 - 11:42 MST
This incident affected: Contact Center (Intermedia).