Issue Dialing Some International Numbers
Incident Report for CallTower
Resolved
CallTower Engineers were able to implement a workaround. CallTower Support has tested this workaround and has been confirmed working. The issue is considered resolved and the associated cases will be closed out.

CallTower will be closing this master case and all associated cases.
Posted Nov 30, 2022 - 11:06 MST
Identified
The issue has been identified/confirmed as an issue related to a high level outage with a CallTower vendor (Lumen). CallTower Engineers are working on a potential workaround.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Nov 30, 2022 - 10:21 MST
Investigating
CallTower Support is investigating multiple reports of an issue dialing out to Canada number only, but has not identified/confirmed there is an issue on our network or with our services.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Nov 30, 2022 - 10:08 MST
This incident affected: Skype for Business (Skype for Business - Voice), Cisco Unified Communications (Cisco Voice), CT Cloud (CT Cloud SIP, CT Cloud Voice), and Microsoft (Microsoft Teams - Direct Routing).