Call Failures
Incident Report for CallTower
Resolved
CallTower Engineers have continued to monitor the issue and have not seen any further issues. CallTower believes the issue has been resolved.

CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request.
Posted Oct 07, 2024 - 14:35 MDT
Monitoring
CallTower Engineers have made a change to route around the issue. Our testing shows that calls are now completing as expected. CallTower will continue to monitor. If you are still experiencing an issue please provide Support with call examples to investigate.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Oct 07, 2024 - 12:36 MDT
Identified
CallTower Engineers are aware of an issue causing call failures for our Teams Operator Connect and are working to resolve it.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Oct 07, 2024 - 12:07 MDT
This incident affected: Microsoft (Microsoft Operator Connect).