Operator Connect Call Queue Calls Failing
Incident Report for CallTower
Resolved
Microsoft has acknowledged the issue and is reporting that it has been resolved. CallTower has confirmed with internal testing that calls made to a call queue are functioning correctly.

CallTower will be closing this master case and all associated cases.
Posted Feb 16, 2023 - 09:59 MST
Update
CallTower engineers continue to investigate issues affecting call queues. We have engaged Microsoft and are escalating for resolution.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Feb 16, 2023 - 09:21 MST
Investigating
CallTower is investigating reports that calls made to an Operator Connect call queue are dropping.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Feb 16, 2023 - 08:50 MST
This incident affected: Microsoft (Microsoft 365).