Intermedia and Teams Dropped Calls

Incident Report for CallTower

Resolved

CallTower continues to see normal call completion. We have seen no further issues affecting call completion for our Intermedia and Teams customers since 9/11 at 11 am MT. CallTower believes the issue has been resolved but continues to work with Microsoft to identify the root cause.

CallTower will be closing this master case and all associated cases.
Posted Sep 13, 2023 - 12:37 MDT

Update

CallTower continues to see successful calls and has not had any new related reports from our customers. CallTower continues to work with our vendors to identify the issue and ensure its resolution.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com.
Posted Sep 12, 2023 - 08:50 MDT

Update

CallTower and customers continue to see normal call completion. Engineering continues to work with associated vendors to ensure the underlying issue has been addressed.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com.
Posted Sep 11, 2023 - 16:16 MDT

Update

CallTower customers have not reported any call drop issue since 11 am MT. Although customers are no longer able to reproduce the issue, CallTower Engineers continue to investigate this issue that is potentially impacting some of our Intermedia and Teams users. If you are still experiencing the issue please report your call examples to support@calltower.com.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 60 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Sep 11, 2023 - 14:23 MDT

Update

CallTower continues to work with our Vendor to investigate the dropped calls. This continues to remain our highest priority. We do not yet have an ETA on resolution.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Sep 11, 2023 - 12:28 MDT

Update

CallTower and our vendor continue to investigate dropped calls affecting our Teams and Intermedia customers. Please continue to provide examples of the affected calls to aid in our investigation.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Sep 11, 2023 - 11:47 MDT

Update

CallTower continues to investigate the issue affecting dropped calls on Intermedia and Teams. We have opened a case with the vendor to assist in our investigation. We don't have an ETA on the resolution yet.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Sep 11, 2023 - 11:13 MDT

Update

CallTower engineers are urgently investigating the issue involving dropped calls with our Intermedia and Teams customers. If you are experiencing the issue, please reach out to support@calltower.com with call examples.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Sep 11, 2023 - 10:39 MDT

Investigating

CallTower is investigating reports of calls dropping for our Intermedia and Teams customers.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Sep 11, 2023 - 10:14 MDT
This incident affected: Contact Center (Intermedia).