CT Cloud Voice Inbound Call Issue
Incident Report for CallTower
Resolved
CallTower has confirmed with customers that services have been restored and believes the issue is resolved. There have been no further reports of the problem from customers.

CallTower will be closing this master case and all associated cases. Within three business days, an official Root Cause Analysis (RCA) or a preliminary RCA will be available and provide to customers upon request.
Posted Jul 27, 2024 - 08:04 MDT
Monitoring
CallTower Engineering continues to research the root cause for the inbound call issue on the CT Cloud Voice Platform. There have been no further reports of the issues from customers, and CallTower Support will continue to monitor the issue.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post the next update on status.calltower.com approximately at 8:00 AM MT, unless identified otherwise. This issue is being investigated as a top priority.
Posted Jul 26, 2024 - 13:59 MDT
Update
CallTower Support has confirmed with multiple customers that the issue is no longer occurring. Our team is working closely with Engineering to urgently identify and resolve the root cause of the inbound call issue on the CT Cloud Voice Platform, prioritizing this matter highly.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 1 hour, unless identified otherwise. This issue is being investigated as a top priority.
Posted Jul 26, 2024 - 13:00 MDT
Update
CallTower Support has confirmed with multiple customers that the issue is no longer occurring. Our team is working closely with Engineering to urgently identify and resolve the root cause of the inbound call issue on the CT Cloud Voice Platform, prioritizing this matter highly.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Jul 26, 2024 - 12:26 MDT
Update
CallTower Support has escalated with Engineering and continues to investigate the inbound call issue on the CT Cloud Voice Platform at a high priority but has not identified or confirmed the source of the issue.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Jul 26, 2024 - 11:49 MDT
Update
CallTower Support continues to investigate the inbound call issue on the CT Cloud Voice Platform, but has not identified or confirmed the source of the issue.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority
Posted Jul 26, 2024 - 11:19 MDT
Investigating
CallTower support is investigating multiple reports of an inbound call issue for the CT Cloud Voice Platform, but has not identified/confirmed there is an issue on our network or with our services.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Jul 26, 2024 - 10:47 MDT
This incident affected: CT Cloud (CT Cloud SIP, CT Cloud Voice).