CT Cloud Contact Center Down
Incident Report for CallTower
Resolved
Intermedia has confirmed that the Connectivity issue with their Virginia Data Center is now considered resolved. All associated cases will be closed out.

CallTower will be closing this master case and all associated cases. CallTower will request an Official Root Cause Analysis (RCA) from Intermedia, and will be available and provided to customers upon request.
Posted Dec 15, 2022 - 12:01 MST
Update
Intermedia's System Administration and Network Engineering Teams continue to actively work towards a permanent resolution to the connectivity issue with their Virginia Data Center.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Dec 15, 2022 - 11:31 MST
Update
CallTower has been notified that Intermedia's Network Engineering Team identified an issue ith their Virginia Data Center impacting user connectivity. Intermedia's System Administration and Network Engineering Teams are actively working towards a resolution. Intermedia has placed a workaround, but some degraded services may still be experienced.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Dec 15, 2022 - 11:01 MST
Identified
CallTower support has identified an issue with CT Cloud Contact Center with CallTower's vendor Intermedia. CallTower continues to work with Intermedia on the issue.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Dec 15, 2022 - 10:29 MST
Investigating
CallTower support is investigating multiple reports of CT Cloud Contact Center down.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Dec 15, 2022 - 10:21 MST
This incident affected: Contact Center (Intermedia).