EMEA outbound calls failing

Incident Report for CallTower

Monitoring

CallTower engineers have completed remediation efforts and service appears to be restored, based on current monitoring and testing. We ask that affected customers please retest their services and confirm that normal functionality has been restored. If you continue to experience any issues, please contact CallTower Support and provide details of the impact so that our teams can investigate further. CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com as any new information becomes available.
Posted Jul 09, 2026 - 06:02 MDT

Update

CallTower Network Engineers have identified a potential cause of the service disruption and are actively working to implement remediation measures. At this time, our engineers are focused on validating the identified cause and restoring full-service stability as quickly as possible. We are continuing to monitor the environment closely and are treating this issue as a top priority. CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise
Posted Jul 09, 2026 - 05:33 MDT

Identified

CallTower engineers are continuing their efforts to isolate and restore services in EMEA for all affected customers. CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise
Posted Jul 09, 2026 - 05:00 MDT

Update

Microsoft Teams and Zoom customers in EMEA are receiving failures when attempting outbound calls. Calltower's voice network engineers have been engaged and are working diligently to restore services in EMEA. CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Jul 09, 2026 - 04:28 MDT

Investigating

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Jul 09, 2026 - 03:57 MDT
This incident affects: Microsoft (Microsoft Teams - Direct Routing, Microsoft Operator Connect) and Zoom.