UK Number Failures
Incident Report for CallTower
Resolved
Bandwidth is reporting that the issue is fixed and that they are monitoring. CallTower has also confirmed with multiple customers that the issue has been resolved.

CallTower will be closing this master case and all associated cases.
Posted Mar 24, 2023 - 06:14 MDT
Identified
CallTower is receiving reports of UK numbers failing. We have opened up with the carrier who is reporting an outage in the UK. Their current status is that the issue has been identified and that they are working to resolve it. We do not yet have an ETA.

*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Mar 24, 2023 - 05:34 MDT
This incident affected: Microsoft (Microsoft Teams - Direct Routing) and Cisco Unified Communications (Cisco Webex Calling).