CT Cloud Fax Failing
Incident Report for CallTower
Resolved
CallTower Engineers have identified and fixed the issue affecting our CT Cloud faxing customers. Our internal testing, as well as confirmation from multiple customers, confirms the issue has been resolved.

CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request.
Posted Jan 15, 2024 - 14:59 MST
Update
CallTower Engineers continue to urgently investigate the issue causing faxes to fail for our CT Cloud Fax Customers. If you are experiencing faxing issues, please open a ticket with support@calltower.com and provide detailed examples to assist in our investigation.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Jan 15, 2024 - 14:13 MST
Investigating
CallTower is investigating reports of faxes failing for our CT Cloud Fax customers. CallTowers engineers are engaged and urgently working the issue.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Jan 15, 2024 - 13:35 MST
This incident affected: Fax (CT Cloud Fax).