Intermedia Contact Center Issues Logging In, Inbound and Outbound Voice Calling Failures

Incident Report for CallTower

Resolved

Some CallTower customers may have briefly experienced issues with Intermedia Contact Center Voice and login. The issue was identified as an Intermedia service outage and has since been resolved.

Update from Intermedia:

Intermedia Engineering teams identified the root cause as a Cloudflare service disruption that affected connectivity to certain Intermedia services. The third-party provider has since restored service, and Intermedia has verified that Email, Contact Center, and Voice services are fully operational. If any issues persist, customers are advised to contact Intermedia Support for assistance.

CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request.
Posted Feb 20, 2026 - 12:15 MST
This incident affected: Contact Center (Intermedia).