CT Cloud Fax Failing
Incident Report for CallTower
Resolved
CallTower continues to see traffic passing across the server normally. There is still a delay and traffic will continue to catch up through out the day. CallTower believes the issue has been resolved.


CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request.
Posted Mar 27, 2023 - 10:11 MDT
Monitoring
CallTower's Engineers have corrected an issue impacting our fax server. Traffic is processing normally and customers should start to see faxes being delivered. There may be a delay as queued traffic catches up.

*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Mar 27, 2023 - 09:33 MDT
Investigating
CallTower is receiving reports of CT Cloud faxes failing. We are actively investigating the issue.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Mar 27, 2023 - 09:00 MDT
This incident affected: Fax (CT Cloud Fax).