Completed
The scheduled maintenance has been completed.
Posted Jul 07, 2026 - 17:10 MDT
Scheduled
As part of our ongoing efforts to protect customers from toll fraud, CallTower is expanding the list of high-risk calling destinations to include select exchanges in Alaska and Montana.
Customers who do not have high-risk calling enabled on their account may be unable to place calls to certain destinations identified as having an elevated fraud risk.
If you are unable to complete calls to a destination and believe there is a legitimate business need, please contact CallTower Support. Our team can help determine whether fraud-prevention controls are affecting call completion and discuss available options.
Posted Jul 07, 2026 - 15:45 MDT
This scheduled maintenance affected: Contact Center (Clarity Connect, Five9, Intermedia, Cisco Webex Contact Center, Solgari), Microsoft (Microsoft 365, Microsoft Teams - Direct Routing, Microsoft Operator Connect, CT Text), Cisco Unified Communications (Cisco Voice, Cisco Jabber, VoiceCube, Attendant Console, Cisco Webex Calling, CT Text), CT Cloud (CT Cloud SIP, CT Cloud Voice, Attendant Console, CT Cloud Meeting), Fax (CT Cloud Fax, Concord E-Fax, Concord ATA Fax, eComFax), Genesys Cloud (Genesys Cloud (US East), Genesys Cloud (US West), Genesys Cloud (Canada), Genesys Cloud (FedRAMP)), and Global SIP Trunk, Hosted Cloud Based PBX, Zoom, WFM (Alvaria), Talk Desk.