CT Cloud Communicator Mobile Inbound calls, Outbound calls, and Login Issues

Incident Report for CallTower

Resolved

CallTower Support has received positive confirmation from affected customers, and the CT Cloud Communicator Mobile issue is considered resolved.

CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request.
Posted Mar 02, 2026 - 13:15 MST

Monitoring

Based on vendor guidance, CallTower Engineering completed a configuration change designed to address the CT Cloud Communicator Mobile issue. CallTower Support will continue to monitor the environment to confirm the issue is fully resolved.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Mar 02, 2026 - 12:37 MST

Update

CallTower Engineering continues to partner with the vendor on log and diagnostic review. The issue has been isolated to an affected system, and investigation is ongoing.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Mar 02, 2026 - 11:32 MST

Update

CallTower Engineering remains engaged with the vendor and is providing logs and diagnostic information as part of the ongoing resolution process.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Mar 02, 2026 - 10:56 MST

Identified

The issues affecting CT Cloud Communicator Mobile have been identified as vendor-related. CallTower engineers are actively working with the vendor to determine and implement a resolution.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Mar 02, 2026 - 10:25 MST

Investigating

CallTower Support is actively investigating multiple reports of inbound and outbound call failures and login issues with CT Cloud Communicator Mobile but has not identified/confirmed there is an issue on our network or with our services.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Mar 02, 2026 - 09:52 MST
This incident affected: CT Cloud (CT Cloud Voice).