CT Cloud Contact Center Calls Stuck in Queue
Incident Report for CallTower
Resolved
The issue with calls not routing to agents with CT Cloud Contact Center (Intermedia) is now resolved. CallTower has confirmed services with multiple customers.

CallTower will be closing this master case and all associated cases. CallTower will work on getting an RCA from Intermedia, and it will be provided to customers upon request.
Posted Jun 05, 2023 - 13:25 MDT
Monitoring
Intermedia has stated they have identified and corrected the issue and are currently monitoring. CallTower and Intermedia are seeing improvement with calls terminating to agents with multiple customers.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Jun 05, 2023 - 12:45 MDT
Identified
The issue with calls stuck in the queue has been identified with CT Cloud Contact Center (Intermedia). Callers can reach customer IVR's and queues, however the calls will stay in the queue for an extended period of time until the call does terminate to an agent. Intermedia's technical team is investigating the issue. CallTower will continue to escalate with Intermedia to push for resolution.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Jun 05, 2023 - 12:17 MDT
Investigating
CallTower support is investigating multiple reports of an issue with CT Cloud Contact Center but has not identified/confirmed there is an issue on our network or with our services.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Jun 05, 2023 - 11:59 MDT
This incident affected: Contact Center (Intermedia).