Outbound Calls Failing

Incident Report for CallTower

Resolved

CallTower engineers have collaborated with our vendor to resolve the issue affecting some outbound calls. We are now observing successful traffic completion.

CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request.
Posted Mar 18, 2025 - 15:31 MDT

Update

CallTower has identified the issue affecting the completion of some outbound calls. CallTower engineers are urgently working with our vendor to implement a fix.

*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Mar 18, 2025 - 15:07 MDT

Investigating

CallTower is urgently investigating reports of some outbound calls failing. We have engaged our carrier to assist in the investigation.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Mar 18, 2025 - 14:40 MDT
This incident affected: Cisco Unified Communications (Cisco Voice), CT Cloud (CT Cloud Voice), and Microsoft (Microsoft Teams - Direct Routing, Microsoft Operator Connect).