Microsoft is reporting that the issue affecting inbound calls to Auto Attendants and Call Queues has been resolved. CallTower has confirmed the resolution in our testing. Microsoft’s incident TM907891 is included below.
"Details Title: Users' calls routed through Auto attendants and Call queues within Microsoft Teams may fail
User impact: Users' calls routed through Auto attendants and Call queues within Microsoft Teams may have failed.
Final status: We've routed the affected call requests to a healthy portion of service infrastructure and confirmed through monitoring service telemetry that impact has been remediated.
Scope of impact: Any user who attempted to make calls routed through Auto attendants and Call queues within Microsoft Teams may have been impacted.
Start time: Thursday, October 10, 2024, at 3:51 PM UTC End time: Thursday, October 10, 2024, at 5:50 PM UTC
Root cause: Auto attendant and Call queue call routed call requests were being routed to an unhealthy portion of service infrastructure, resulting in impact.
Next steps: - We're continuing to monitor the affected infrastructure closely to gain further insight into the source of the underlying issue and better prevent similar impact in the future. - We’re assessing our automated recovery mechanisms in conjunction with our findings into the underlying problem to identify areas for improvement to reduce the time to mitigate similar future issues.
This is the final update for the event."
CallTower will be closing this master case and all associated cases.
Posted Oct 10, 2024 - 12:33 MDT
Identified
CallTower continues to work with Microsoft on the issue affecting inbound calls to Teams Auto Attendants and Call Queues. Microsoft is working on rerouting traffic to fix this issue now and will provide further updates shortly. CallTower is seeing some successful calls in our internal testing and testing reported by customers.
Posted Oct 10, 2024 - 12:00 MDT
Update
CallTower continues to urgently investigate the issues affecting inbound calls for Microsoft Teams Operator Connect and Direct routing Auto Attendants and Call Queues. Microsoft has acknowledged a global outage at this time and is working to resolve it. If you need assistance in forwarding numbers, please reach out to support@calltower.com. Microsoft’s most recent update is provided below.
Issue ID: TM907891 Affected services: Microsoft Teams Status: Investigating Issue type: Advisory Start time: Oct 10, 2024, 12:14 PM CDT
Current status Oct 10, 2024, 12:14 PM CDT We're investigating a potential issue with users' Auto Attendant and Call Queue calls failing within Microsoft Teams, and we're checking for impact to your organization. We'll provide an update within 30 minutes.
Posted Oct 10, 2024 - 11:32 MDT
Investigating
CallTower is investigating reports of inbound calls ringing busy.
CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Oct 10, 2024 - 10:49 MDT
This incident affected: Microsoft (Microsoft 365, Microsoft Teams - Direct Routing, Microsoft Operator Connect).