CT Text Access and Performance Issues
Incident Report for CallTower
Resolved
Calltower has confirmed with vendor that the service disruption was related to the global Microsoft outage. Our partner has advised that service automatically recovered when the Azure service in Central US was restored and is now functioning normally. However, we will continue to monitor the situation closely. CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request.

For more information, here are some links to news headlines related to the global outage:

- https://nam02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.cnbc.com%2F&data=05%7C02%7Cdylan.lewis%40calltower.com%7C67c16343632949e60e8008dca7cde6b1%7C34a23b7014ed448cb453c1a79a3e5d27%7C0%7C0%7C638569750047095442%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C0%7C%7C%7C&sdata=01BWviVjH8Kd6Jw5EpZsHIa4Iuj4P%2BvpywvUx3aD5VM%3D&reserved=0
- https://nam02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.bbc.com%2F&data=05%7C02%7Cdylan.lewis%40calltower.com%7C67c16343632949e60e8008dca7cde6b1%7C34a23b7014ed448cb453c1a79a3e5d27%7C0%7C0%7C638569750047594188%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C0%7C%7C%7C&sdata=HfDw3Iomfq2PX6JDQOum5befpR7Dw5tNFtxAkwbnkYU%3D&reserved=0
- https://nam02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.cnbc.com%2F&data=05%7C02%7Cdylan.lewis%40calltower.com%7C67c16343632949e60e8008dca7cde6b1%7C34a23b7014ed448cb453c1a79a3e5d27%7C0%7C0%7C638569750047602998%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C0%7C%7C%7C&sdata=733Ezq3EWkZpRhAdizf1vKCSX%2FzUPHwFUJ0BJL%2FhxjA%3D&reserved=0
Posted Jul 19, 2024 - 09:20 MDT
Update
Investigating: CallTower support has escalated with our vender and understand the urgency of this issue, CallTower will provide updates as they are received.

Customers may experience loading issues, timeouts, or errors when trying to access the application in both Microsoft Teams and Webex.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com as we receive them., unless identified otherwise. This issue is being investigated as a top priority
Posted Jul 18, 2024 - 18:24 MDT
Investigating
Investigating: CallTower support is currently investigating an issue with the CT Text application. Customers may experience loading issues, timeouts, or errors when trying to access the application in both Microsoft Teams and Webex. We are working closely with our vendor to urgently address and mitigate the impact.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 60 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Jul 18, 2024 - 16:57 MDT
This incident affected: Microsoft (CT Text) and Cisco Unified Communications (CT Text).