Operator Connect Number Management Issues
Incident Report for CallTower
Resolved
This incident has been resolved.
Posted Jul 17, 2024 - 07:53 MDT
Monitoring
Services have been restored for Operator Connect. Microsoft has identified an issue with their API code which is causing a memory leak. Microsoft is putting in a mitigation process (a redeployment of services) to control the leak until they can fully resolve the problem. CallTower and Microsoft will continue to monitor the issue and will provide updates once Microsoft has completed the code upgrade.
Posted Jul 08, 2024 - 13:23 MDT
Investigating
CallTower is investigating reports of delayed provisioning in CallTower Connect for Teams Operator Connect. Our Engineering teams are working with Microsoft to identify and resolve the issue.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. This issue is being investigated as a top priority.
Posted Jul 08, 2024 - 11:45 MDT
This incident affected: Microsoft (Microsoft Operator Connect) and CallTower Connect.