CT Cloud Contact Center Issue with Calls Not Routing to Agents
Incident Report for CallTower
Resolved
Intermedia has confirmed this issue with calls routing to agents has been resolved. CallTower will be closing this master case and all associated cases.
Posted Jun 05, 2023 - 16:53 MDT
Monitoring
CallTower's customers are not currently experiencing any issues. We will continue to monitor and notify if there is any additional service issues or when we get confirmation from Intermedia the issue has been fully resolved.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com.
Posted Jun 05, 2023 - 16:16 MDT
Identified
Intermedia is attempting to mitigated the issue and believe they have isolated the source of the issue. Customers are reporting intermittent issue with calls not routing to agents. CallTower will continue to work with and escalate this issue with Intermedia.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Jun 05, 2023 - 15:37 MDT
Investigating
CallTower support is investigating multiple reports of an issue with CT Cloud Contact Center (Intermedia) calls not routing to agents.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Jun 05, 2023 - 14:48 MDT
This incident affected: Contact Center (Intermedia).