Microsoft Direct Routing
Incident Report for CallTower
Resolved
Calltower engineers and impacted customers have confirmed that the patch implemented by our SBC partner has restored service.

CallTower will be closing this master case and all associated cases. Within three business days, an official Root Cause Analysis (RCA) or a preliminary RCA will be available and provided to customers upon request.
Posted Feb 07, 2023 - 14:07 MST
Monitoring
Calltower engineers working in tandem with our SBC partner believe that the underlying issue was identified and have applied a patch to alleviate impact on outbound calls for a very limited number of Direct Routing customers. We are currently evaluating the the change to validate that the impact has been eliminated. At this time we are asking that impacted customers retest.

*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Feb 07, 2023 - 13:45 MST
Update
Calltower's engineers are actively working to identify and restore service impacting very limited number of users.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Feb 07, 2023 - 13:02 MST
Investigating
We are currently investigating reports of outbound call failures for Legacy Onestream Direct Routing Customers.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Feb 07, 2023 - 12:26 MST
This incident affected: Microsoft (Microsoft Teams - Direct Routing).