Unable to Log In to CT Cloud Communicator
Incident Report for CallTower
Resolved
The problem with users not being able to log into CT Cloud Communicator Desktop is fixed. CallTower worked with our vendor and found a bug that was preventing users from logging in. CallTower engineers are working on a permanent fix. Affected users should close and reopen the CTCC Desktop app, then log back in.

CallTower will close this case and related cases. An Official or Preliminary Root Cause Analysis (RCA) will be available within three business days and provided to customers upon request. The issue is resolved, and the cases will be closed.
Posted Nov 08, 2024 - 13:34 MST
Investigating
CallTower support is investigating multiple reports of users unable to log into the CT Cloud Communicator, but has not identified/confirmed there is an issue on our network or with our services.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Nov 08, 2024 - 12:36 MST
This incident affected: CT Cloud (CT Cloud SIP, CT Cloud Voice).