Five9 Service Degradation – Call Performance and Connectivity Issues

Incident Report for CallTower

Resolved

CallTower Support has confirmed resolution of the Five9-related issues that were impacting call delays, audio issues, browser speed, and connection issues to Five9. The issue was addressed in coordination with Five9 Engineering, and services are operating normally at this time.

CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request.
Posted Apr 29, 2026 - 12:59 MDT

Investigating

CallTower Support has received reports of issues impacting some Five9 customers. Users may experience call delays, Audio issues, intermittent slow browser speed, and connection issues to Five9. CallTower support is currently investigating with Five9 engineering to mitigate and resolve these issues.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 60 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Apr 29, 2026 - 11:22 MDT
This incident affected: Contact Center (Five9).