Outbound Calls Failing for GCC High SME customers
Incident Report for CallTower
Resolved
CallTower has identified the issue and applied a fix which is now allowing outbound calls to route normally. CallTower continues to monitor calls and asks that customers report any continued issues to support@calltower.com.

CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request.
Posted Nov 22, 2023 - 05:57 MST
Update
CallTower continues to urgently work on this issue. At this time we have called each of the reporting customers to schedule a time to implement a workaround. This workaround has been tested and does resolve the issue affecting outbound calling for our GCC High customers. CallTower will continue to work directly with the affected customers and provide our next update at 8:00 AM ET.

*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com.
Posted Nov 21, 2023 - 19:09 MST
Update
CallTower continues to work with Microsoft to resolve the issue affecting outbound calls for our GCC High customers. CallTower is reaching out to affected customers to implement a workaround that restores outbound calling functionality. We do not yet have an ETA on resolution. This continues to remain our highest priority.
Posted Nov 21, 2023 - 18:20 MST
Update
CallTower is urgently investigating the issue affecting outbound calls for our Microsoft Teams GCC High customers. Our previously mentioned changes did not resolve the issue. We have opened a priority case with Microsoft to assist in the investigation. We do not yet have any eta on the resolution.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 60 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Nov 21, 2023 - 16:18 MST
Update
CallTower engineers continue to urgently work this issue. We believe we have identified an issue and are currently testing a potential fix in our internal testing environment. We will roll this fix out to the affected customers once confirmed. We do not yet have an ETA.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 60 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Nov 21, 2023 - 15:00 MST
Update
CallTower continues to urgently investigate this issue. We do not yet have an ETA on the resolution. This continues to only affect a subset of our GCC High customers.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Nov 21, 2023 - 13:43 MST
Update
CallTower continues to investigate an issue affecting outbound calling for our GCC High customers. Our engineering teams are urgently working the issue. We ask that customers continue to report failed calls to Support@calltower.com

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Nov 21, 2023 - 12:57 MST
Investigating
CallTower is investigating reports of GCC High outbound calls failing. This appears to only be affecting a subset of our customers on GCC High. CallTower has made a change and is asking customers to retest and report any failed outbound calls to support@calltower.com
Posted Nov 21, 2023 - 12:14 MST
This incident affected: Microsoft (Microsoft Teams - Direct Routing).