CT Cloud Fax Failures
Incident Report for CallTower
Resolved
CallTower Support has worked with CallTower Engineers, and have run successful fax tests after recovering system processes that unexpectedly stopped running. We have had confirmed test results from several customers. CallTower Engineers continue to investigate the root cause.

CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request.
Posted Dec 21, 2023 - 10:27 MST
Investigating
CallTower support is investigating multiple reports of CT Cloud Fax failures but has not identified/confirmed there is an issue on our network or with our services.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Dec 21, 2023 - 09:16 MST
This incident affected: Fax (CT Cloud Fax).