Intermedia login error.
Incident Report for CallTower
Resolved
CallTower has verified that customers can successfully log in by adding "@CC_accountID.com" to their usernames. Consequently, we consider this issue resolved. If customers wish to update their usernames to add their "@domain.com", please contact support@calltower.com to initiate a case for the request.

CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request
Posted Mar 21, 2024 - 10:52 MDT
Identified
CallTower has initiated master case 01323257 to address an issue affecting users encountering login errors while accessing Intermedia. The error indicates incorrect username/password. Upon investigation, it was found that Intermedia implemented a new username policy, automatically updating usernames not in "email format" to include "@CC_'accountID.com" to their existing usernames. Passwords remain unchanged. We kindly ask users experiencing login errors to append "@CC_accountID.com" to their existing usernames when logging into Intermedia.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 60 minutes, unless identified otherwise.
Posted Mar 21, 2024 - 08:47 MDT
This incident affected: Contact Center (Intermedia).