CT Cloud Communicator Failed Update

Incident Report for CallTower

Resolved

This incident has been resolved.
Posted Jan 02, 2026 - 09:24 MST

Investigating

CallTower engineers have identified and resolved an issue impacting customers using CT Cloud Communicator. The problem was caused by a failed update that did not download correctly, resulting in application failures.
To restore service, our engineers have reverted the update and will not reapply it until we have confirmed with the vendor that it can be deployed successfully. This will not affect customers who have manually updated to the newest version of the app; they can continue to use it without issue.
A detailed summary of the event is provided below. If you continue to experience any issues, please contact CallTower Support for assistance.

Start Time: Around 6:30 AM MST
End Time: 8:18 AM MST
Resolution Action: The update was rolled back to the previous version.
Posted Jan 02, 2026 - 09:23 MST
This incident affected: CT Cloud (CT Cloud Voice, CT Cloud Meeting).