Intermedia Contact Center Issues
Incident Report for CallTower
Resolved
Intermedia is reporting that the issue affecting login and calling has been resolved. CallTower has also confirmed resolution with several customers.

CallTower will be closing this master case and all associated cases.
Posted Jul 19, 2024 - 12:14 MDT
Update
CallTower continues to monitor the issue which is related to the global CrowdStrike outage. Intermedia reports that they are working with CrowdStrike to resolve the issue. Please reach out to CallTower Support if you need assistance in temporarily forwarding numbers.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to
support@calltower.com
Posted Jul 19, 2024 - 11:39 MDT
Monitoring
CallTower continues to monitor the issue. We are currently pending an ETA on complete resolution but we have confirmed with some customers that they are again able to access the CCA application. We will continue to provide updates as we receive them.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com.
Posted Jul 19, 2024 - 06:40 MDT
Update
CallTower continues to work with Intermedia on the issue. Intermedia reports that the issue has been identified and a fix is being implemented. The Intermedia update is provided below. We do not yet have an ETA on resolution.

Update from Intermedia:
“Business impact:
Some Account Administrators may continue to experience issues with login to Control Panels. Some users may continue to experience degraded performance connecting to services.
Summary of issue:
We want to update you on the significant global outage affecting Intermedia services due to a recent CrowdStrike update. This issue has disrupted many businesses worldwide, including airlines, banks, and technology companies. This outage has impacted Microsoft Windows systems that support Intermedia's services.
Technical details:
CrowdStrike has identified, isolated, and deployed a fix for the issue. Like all impacted organizations, we are now working to restore all our services. While many of our services are operational, some remain affected, and our teams are working tirelessly to resolve this as quickly as possible. We will keep you informed as we have more updates. Thank you for your continued patience and understanding.”
Posted Jul 19, 2024 - 05:34 MDT
Update
CallTower continues to work with Intermedia on the issue affecting access to the CCA application. Intermedia reports that they continue to be impacted by a global outage with CrowdStrike. The most recent intermedia update is provided below. CallTower will continue to monitor the issue and provide updates as we receive them.

Intermedia Update:
“Summary of issue:

We want to inform you about a significant global outage that is currently affecting Intermedia services. This issue stems from a recent update by cybersecurity firm CrowdStrike, which has caused widespread disruptions for airlines, banks, media outlets, technology companies, telecom firms, and businesses and other organizations around the world. This outage has impacted Microsoft Windows systems that support Intermedia"s services.

Business impact:

Account Administrators may experience issues with login to Control Panels. Users may experience degraded performance connecting to services.

Technical details:

Many of our services and systems are working, but not all. CrowdStrike has communicated that they are in the process of rolling back the update that caused this issue. We understand the critical nature of the services we provide and regret any inconvenience this may cause. Our teams are working nonstop to resolve this issue as quickly as possible and to minimize the impact on your operations. We will keep you updated on the progress and provide further information as it becomes available. Thank you for your patience and understanding during this time.
Jul 19, 2024 - 05:23 EDT”
Posted Jul 19, 2024 - 04:12 MDT
Identified
CallTower is investigating reports of issues affecting the ability to log in and receive calls through the Intermedia contact center application. Intermedia is aware of the issue and has acknowledged that it is a part of a larger outage. Intermedia's most recent post is included below. CallTower will continue to work with the vendor and post updates as we receive them.

From Intermedia:
"Business Impact:
Crowdstrike, a prominent security company utilized by Intermedia, is experiencing an outage that is affecting thousands of customers worldwide.

Summary of issue:
Our Team has identified a connectivity issue affecting some services availability due to a problem with Crowdstrike. The issue is being investigated and we will provide further updates as soon as we have them.

Technical Details:
Our Team has identified issues with service availability due to a problem with Crowdstrike. Crowdstrike is working to solve the issues and restore service as quickly as possible. We will provide further updates as soon as we have them."
Posted Jul 19, 2024 - 02:31 MDT
This incident affected: Contact Center (Intermedia).