Brief Service Interruption
Incident Report for CallTower
Resolved
The brief interruption issue is considered resolved and the associated cases will be closed out.

CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request.
Posted Apr 01, 2024 - 14:30 MDT
Investigating
CallTower customers may have experienced a brief interruption in services, which are currently up and running. CallTower Engineers are investigating the cause of the interruption.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Apr 01, 2024 - 11:03 MDT
This incident affected: Skype for Business (Skype for Business - Voice), Contact Center (Clarity Connect, Five9, Intermedia, Cisco Webex Contact Center), Cisco Unified Communications (Cisco Voice, Cisco Webex Calling), CT Cloud (CT Cloud SIP, CT Cloud Voice), and Microsoft (Microsoft Teams - Direct Routing).