Inbound Calling Issues
Incident Report for CallTower
Resolved
Peerless is reporting that services are now restored. CallTower is getting reports from customers that numbers are again working.

CallTower will be closing this master case and all associated cases.
Posted Jun 20, 2022 - 10:18 MDT
Update
CallTower continues to escalate and work with Peerless management. We do not yet have an ETR from Peerless. CallTower is however seeing some successful traffic across Peerless numbers.


*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Jun 20, 2022 - 09:47 MDT
Update
Peerless continues to work on the issue. CallTower has escalated to the highest levels at Peerless and continues to actively push for an ETR and resolution.



*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Jun 20, 2022 - 09:16 MDT
Update
Peerless continues to work on the issue. CallTower is actively escalating and pushing for resolution.

*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Jun 20, 2022 - 08:45 MDT
Identified
CallTower continues to work with Peerless who has identified an issue in their network. The carrier is actively engaged and working the issue.



*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Jun 20, 2022 - 08:15 MDT
Update
CallTower has identified that the affected calls are coming from our carrier Peerless. CallTower Engineers are working with the carrier to investigate the issue.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Jun 20, 2022 - 07:45 MDT
Investigating
CallTower is investigating multiple reports of CT Cloud inbound calls having one-way audio or no audio.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Jun 20, 2022 - 07:12 MDT
This incident affected: Cisco Unified Communications (Cisco Voice), CT Cloud (CT Cloud Voice), and Microsoft (Microsoft Teams - Direct Routing).