Microsoft Auto Attendant Issues
Incident Report for CallTower
Resolved
Microsoft has stated that this issue is now resolved. If there were any forwards in place we will get those removed. Here is the update provided by Microsoft on their ticket TM394507.

Title: Users' calls to auto attendants may fail to transfer after selecting an option
ID: TM394507

Status: Service Restored

Restored Services: Microsoft Teams

Details:
Title: Users' calls to auto attendants may fail to transfer after selecting an option
User Impact: Users' calls to auto attendants may have failed to transfer after selecting an option.
More info: After users selected an option from the auto attendant menu, there was no audio for up to three minutes, the call stated that it couldn't connect, and then the call disconnected.
Final status: We've determined that a recent update to service components that facilitate auto attendant functionality contained a regression. We've reverted the update and confirmed via telemetry that the impact is resolved.
Scope of impact: This issue could have potentially affected any users' calls to an auto attendant when transferring their call after selecting an option.

Start time: Tuesday, June 21, 2022, at 1:30 PM MT

End time: Tuesday, June 21, 2022, at 4:20 PM MT

Root cause: A recent update to service components that facilitate auto attendant functionality contained a regression.
Next steps:
- To help prevent similar impact in the future, we're further reviewing the underlying cause of the regression and how we can improve our validation procedures to catch such issues before deployment.
This is the final update for the event.

CallTower will be closing this master case and all associated cases.
Posted Jun 21, 2022 - 17:13 MDT
Update
CallTower engineers continue to work with Microsoft to investigate issues affecting Microsoft Teams auto attendants. Microsoft has provided the below update on their ticket TM394507.


Title: Users' calls to auto attendants may fail to transfer after selecting an option User Impact: Users' calls to auto attendants
may fail to transfer after selecting an option. More info: After users select an option from the auto attendant menu, there is no audio for up to three minutes, the call then states that it couldn't connect and disconnects the call. Current status: We're reviewing
provided call IDs from some affected users and reviewing telemetry surrounding call connectivity to determine the source of the issue. Scope of impact: This issue could potentially affect any users' calls to an auto attendant when transferring their call after
selecting an option. Next update by: Tuesday, June 21, 2022 at 11:00 PM UTC (5:00 MT)


*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 60 minutes, unless information is received earlier from Microsoft. This issue is being investigated as a top priority.
Posted Jun 21, 2022 - 16:33 MDT
Update
CallTower engineers are investigating an issue affecting call transfers from Auto Attendants in Microsoft Teams. CallTower is working with Microsoft, who has acknowledged and opened TM394507 to track this issue. Information provided Microsoft: June 21, 2022 3:32 PM MT
Title: Users' calls to auto attendants may fail to transfer after selecting an option User Impact: Users' calls to auto attendants may fail to transfer after selecting an option. More info: After users select an option from the auto attendant menu, the call plays dead air for up to three minutes, then the call states that it couldn't connect and to try again later, and disconnects the call. Current status: We're investigating a potential issue and checking for impact to your organization. We'll provide an update within 30 minutes. Scope of impact: Your organization is affected by this event, and any users' calls to an auto attendant may fail to transfer after selecting an option.


*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Jun 21, 2022 - 16:00 MDT
Investigating
CallTower is investigating reports of routing and dead air issues when calling a Microsoft Teams Auto Attendant.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Jun 21, 2022 - 15:30 MDT
This incident affected: Microsoft (Microsoft Teams - Direct Routing).