CT Cloud Contact Center Agent Login Issues
Incident Report for CallTower
Resolved
Telax is reporting they have corrected the sign-in issue for WebCCA agents. CallTower is working with customers to validate services have normalized.

If you continue to experience issues, please contact CallTower Support at 800-347-5444 or support@calltower.com.
Posted Jan 23, 2020 - 08:29 MST
Investigating
CT Cloud Contact Center (Telax) agents are currently experiencing issues signing into their agent console. CallTower is working with our vendor, Telax, to identify the root cause of the issue. Please contact CallTower Support is you are experiencing any of these issues or if you’d like numbers rerouted until this issue is resolved at 800-347-5444 or support@calltower.com.
Posted Jan 23, 2020 - 07:36 MST
This incident affected: Contact Center (Telax).