Connectivity Issues
Incident Report for CallTower
Resolved
Services were normalized earlier today by utilizing connectivity through alternate routes. CallTower engineers worked with the Carrier and determined a problem with a piece of equipment on the carrier’s network. The carrier corrected the problem which restored the circuit. All services are fully functional.
Posted Jul 10, 2020 - 17:18 MDT
Update
CallTower has seen services normalize as the connectivity issues were isolated and bypassed through a secondary path. CallTower will continue to work with the underlying carrier to identify the root-cause and ensure stability prior returning to the primary path.

If you continue to experience any issues, please contact support@calltower.com.
Posted Jul 10, 2020 - 10:11 MDT
Monitoring
CallTower Engineers are monitoring an issue that is affecting customers across multiple platforms. Two circuits in CallTower’s Atlanta data center had temporarily lost connection. CallTower Engineers are actively working to isolate the issue and minimize any further service interruption.

Please contact CallTower Support at support@calltower.com if you believe you are being affected by this outage.
Posted Jul 10, 2020 - 09:38 MDT
This incident affected: Skype for Business (Skype for Business - Voice) and Cisco Unified Communications (Cisco Voice).