CallTower Status
All Systems Operational

About This Site

Welcome to CallTower's home for real-time system status updates. Here you will find a current and historical data on system performance.

Cisco Unified Communications Operational
Cisco Voice Operational
Cisco Jabber ? Operational
VoiceCube Operational
Attendant Console Operational
Cisco Webex Calling Operational
CT Cloud Operational
CT Cloud SIP ? Operational
CT Cloud Voice ? Operational
Attendant Console Operational
CT Cloud Meeting Operational
Microsoft Operational
Microsoft 365 Operational
Microsoft Teams - Direct Routing Operational
Microsoft Operator Connect Operational
CT Text Operational
Contact Center Operational
Clarity Connect Operational
Five9 Operational
Intermedia Operational
Cisco Webex Contact Center Operational
Global SIP Trunk Operational
Hosted Cloud Based PBX Operational
Zoom Operational
CallTower Connect Operational
Fax Operational
CT Cloud Fax Operational
Concord E-Fax Operational
Concord ATA Fax Operational
eComFax Operational
Skype for Business Operational
Skype for Business - Voice ? Operational
Instant Messenger and Presence Operational
Attendant Console Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Past Incidents
Mar 28, 2024
Resolved - Microsoft indicated a network routing change through their infrastructure caused inbound and outbound calls to fail starting at 5:50 AM MDT. They have corrected the issue as of 6:20 AM MDT and are monitoring. Additional details can be found by your Microsoft 365 Admin under Service Health, and TM760143. We will be closing all related cases shortly. If you continue to experience issues, please submit a ticket to support@calltower.com or call 1-800-347-5444.
Mar 28, 07:43 MDT
Mar 27, 2024

No incidents reported.

Mar 26, 2024

No incidents reported.

Mar 25, 2024

No incidents reported.

Mar 24, 2024

No incidents reported.

Mar 23, 2024

No incidents reported.

Mar 22, 2024

No incidents reported.

Mar 21, 2024
Resolved - CallTower has verified that customers can successfully log in by adding "@CC_accountID.com" to their usernames. Consequently, we consider this issue resolved. If customers wish to update their usernames to add their "@domain.com", please contact support@calltower.com to initiate a case for the request.

CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request

Mar 21, 10:52 MDT
Identified - CallTower has initiated master case 01323257 to address an issue affecting users encountering login errors while accessing Intermedia. The error indicates incorrect username/password. Upon investigation, it was found that Intermedia implemented a new username policy, automatically updating usernames not in "email format" to include "@CC_'accountID.com" to their existing usernames. Passwords remain unchanged. We kindly ask users experiencing login errors to append "@CC_accountID.com" to their existing usernames when logging into Intermedia.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 60 minutes, unless identified otherwise.

Mar 21, 08:47 MDT
Mar 20, 2024

No incidents reported.

Mar 19, 2024

No incidents reported.

Mar 18, 2024

No incidents reported.

Mar 17, 2024

No incidents reported.

Mar 16, 2024
Completed - The scheduled maintenance has been completed.
Mar 16, 04:00 MDT
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 15, 22:00 MDT
Scheduled - Purpose: Patching and preventative maintenance on multiple systems.
Systems Affected:

CT Cloud Voice:
-MasterFax & CT Cloud Fax - General Server Maintenance
***Possible Impact: Customers will experience interruptions to both MasterFax and CT Cloud Fax services during the Maintenance Window.
-MasterFax & CT Cloud Fax - Server Licensing Update
***Possible Impact: Customers will experience interruptions to both MasterFax and CT Cloud Fax services during the Maintenance Window.

Microsoft:
-Skype Internal Cert Renewals
***Possible Impact: Skype clients may sign in and out during this renewal process.
-Skype Wildcard Cert Renewal
***Possible Impact: Skype clients may sign in and out during this renewal process.
-Skype Pool 4 Cert Renewal
***Possible Impact: Skype clients may sign in and out during this renewal process.

Cisco:
-Reboot mra.ct450.com Servers
***Possible Impact: CallTower will be rebooting Edge servers for mra.ct450.com. Phones are expected to be down for no more than a few minutes and should connect as usual once servers are restarted.
-Update Wildcard *.ct750.com cert and apply to Mutare servers
***Possible Impact: Cisco HCS Voice Transcription - CallTower will be loading a Public Certificate to the Voice Transcription servers. It is possible some messages will not have the transcription while new cert is being applied.

All Platforms:
-Upgrade Route Processors in New York and Los Angeles Datacenters
***Possible Impact: Connections to the NY and LA Sansay will see some disruption as the hardware in those datacenters is upgraded. Anyone with failover configured correctly between LA and NY will not see any downtime. Any Colo customer in NY and LA will also see a disruption in service.

Mar 8, 15:59 MST
Mar 15, 2024
Mar 14, 2024

No incidents reported.