Microsoft 0365 Outage
Incident Report for CallTower
Resolved
This incident has been resolved.
Posted 19 days ago. Jan 29, 2019 - 16:13 MST
Monitoring
CallTower Support is monitoring an intermittent issue with connectivity to the Microsoft O365 product suite. Microsoft’s hosted services were impacted by a service interruption causing users to lose connectivity to hosted services, regardless of license provider.

CallTower’s Skype for Business voice services were not affected by this issue. CallTower customers may have been impacted if their services included Microsoft’s hosted Unified Messaging (voicemail and auto-attendants), federation services and Clarity Federated services.

CallTower Engineering is monitoring the issue at this time and reaching out to Microsoft for a root-cause analysis. If you experience issues related to your CallTower services please contact support@calltower.com or at 800-347-5444.
Posted 19 days ago. Jan 29, 2019 - 15:03 MST
This incident affected: Contact Center (Clarity Connect), Skype for Business (Skype for Business - Voice, Instant Messenger and Presence, Attendant Console), and Microsoft O365/Teams.