Atlanta Data Center Connectivity
Incident Report for CallTower
Resolved
CallTower has seen services normalize from internal monitoring and customer validation. At this time we will be closing out the master case and associated cases.

If you continue to experience any issues, please reach out to our support team at support@calltower.com.
Posted Mar 06, 2020 - 18:32 MST
Monitoring
CallTower has restored connectivity through another carrier. We believe all services are normalizing for customers however a few of our hosted Skype for Business customers are experiencing long post-dial delays (time to connect calls). We are exploring and resolving this issue.

CallTower will continue to monitor services as CenturyLink technicians are continuing to finalize the fiber repair. CenturyLink is reporting the following update:
“Event Field Operations have isolated the damage to the creek and will be splicing around the damaged section as a temporary repair.”

Please reach out to our support team at support@calltower.com for any questions regarding this issue. We will post additional updates by or before 6:30 pm MT.
Posted Mar 06, 2020 - 16:27 MST
Update
Century Link technicians are continuing to work to repair the fiber cut. At 1:36 MT Century Link is reporting the following update:

“The Transport NOC and Field Operations are starting an urgent network maintenance event to repair the fiber issue in Atlanta, GA.”

CallTower Engineers have restored connectivity via a redundant path that will restore additional services. Another update on service restoration will be posted by 3 PM MT or sooner if additional information is available.

Please reach out to our support team at support@calltower.com for any questions regarding this issue.
Posted Mar 06, 2020 - 14:19 MST
Update
CallTower’s circuit provider, CenturyLink, has acknowledged a fiber cut on the connection to CallTower’s Atlanta data center. The fiber cut is affecting numerous customers in the Atlanta area. Century Link technicians are onsite splicing new fiber; however, there is currently no estimated time to resolution (ETTR).

Skype for Business services have normalized and customers have reported they are no longer experiencing issues. Other services and those with inbound numbers routed through our Atlanta data center may still be impacted until the fiber cut is repaired.

If you are experiencing issues, please contact support@calltower.com. Another update on the fiber cut will be provided by 2 PM MT.
Posted Mar 06, 2020 - 13:10 MST
Update
CallTower Engineers have completed the failover to geo-redundant locations for Skype for Business customers. Skype for Business users are continuing to see services come back online, and CallTower Engineering is validating the full restoration of services.

Select services have not failed over to geo-redundant locations, such as BoadRiver Communications Corp (BRCC) customers, faxing platforms, and select Atlanta area telephone numbers.

CallTower is continuing to address the connectivity issue into the Atlanta data center. The circuit provider has indicated our connectivity issue has been related to a higher-level outage in the area. CallTower is escalating the issue with our circuit provider.

If you are experiencing issues, please contact support@calltower.com. An additional update will be provided by 1:00 PM MT.
Posted Mar 06, 2020 - 12:10 MST
Identified
CallTower is investigating an issue in our Atlanta Data Center that is affecting multiple platforms. Our engineering teams are currently ensuring all services are failed over to geo-redundant locations. Users may see services come back online as they are moved to an alternate data center.

If you are experiencing issues, please contact support@calltower.com. Another update will be provided by 12:00 PM MT.
Posted Mar 06, 2020 - 11:25 MST
This incident affected: CT Cloud (CT Cloud SIP, CT Cloud Voice, CT Cloud Fax), Skype for Business (Skype for Business - Voice), and Cisco Unified Communications (Cisco Voice).