CT Cloud Fax Inbound and Outbound Fax Failures
Incident Report for CallTower
Resolved
The CT Cloud Fax inbound and outbound fax failure issue is considered resolved and the associated cases will be closed out. Faxes will continue to be processed throughout the day, but a delay may be experienced as the backlog of faxes process.

CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request.
Posted Dec 05, 2022 - 11:10 MST
Update
CallTower continues to monitor CT Cloud Fax and are seeing services normalize and continue to process.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Dec 05, 2022 - 10:38 MST
Monitoring
CallTower is seeing CT Cloud Fax services starting to clear, inbound and outbound faxes are processing. Faxes may be delayed due to the backlog of faxes processing.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Dec 05, 2022 - 09:58 MST
Identified
The CT Cloud Fax issue has been identified as an issue with The CallTower vendor. CallTower Engineers are working directly with the vendor towards resolution.

CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Dec 05, 2022 - 09:45 MST
Investigating
CallTower support investigating multiple reports of CT Cloud Fax inbound and outbound fax failures, but has not yet identified/confirmed there is an issue on our network or with our services.

CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Dec 05, 2022 - 09:09 MST
This incident affected: Fax (CT Cloud Fax).