Skype for Business (SfB) and Clarity Connect Connection Issues
Incident Report for CallTower
Resolved
CallTower engineering is continuing to review the client logs provided by customers. Initial review indicates a possible customer-side DNS issue. Customers are reporting services have normalized. CallTower engineering will continue to review logs and communicate their findings in a Root Cause Analysis (RCA).

Default messaging: CallTower will be closing this master case and all associated cases. Within three business days, an Official RCA or a Preliminary RCA will be available and provided to customers upon request.
Posted Apr 07, 2021 - 13:45 MDT
Update
CallTower is receiving reports that services have normalized for affected customers. CallTower Support is continuing to work with customers to gather client logs. Additional logs are needed to identify the root-cause of the issue. Please forward any client logs to support@calltower.com

*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Apr 07, 2021 - 13:10 MDT
Investigating
CallTower is currently investigating reports of server connection issues on Skype for Business (SfB) and Clarity Connect. Examples have been escalated to our engineering team for review.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Apr 07, 2021 - 12:33 MDT
This incident affected: Skype for Business (Skype for Business - Voice) and Contact Center (Clarity Connect).