Inbound Calling Issues
Incident Report for CallTower
Resolved
CallTower engineers have identified and resolved an issue with a Session Border Controller (SBC) that briefly interrupted inbound calling for Teams Direct Routing customers. CallTower is seeing services normalize. Please reach out to support@calltower.com if you continue to have any issues.

Within three business days, an Official Reason for Incident(RFI) or a Preliminary RFI will available and be provided to customers upon request.
Posted Jan 05, 2021 - 14:41 MST
Investigating
CallTower is investigating reports of inbound call failures for Microsoft Teams Direct Routing customers. The reports have been escalated to CallTower Engineering for review. More information will be provided in the next 30 minutes.


*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes unless identified otherwise. This issue is being worked on as a top priority.
Posted Jan 05, 2021 - 14:19 MST
This incident affected: Microsoft Teams - Direct Routing.