Clarity Dashboard Error Message
Incident Report for CallTower
Resolved
A fix has been implemented by Perficient and services have normalized. CallTower engineering has tested this on known affected customers and confirmed this issue is resolved.

If you continue to have issues with Clarity Connect dashboard interactions with your Skype for Business service please contact support@calltower.com or 800-347-5444.
Posted 16 days ago. Feb 01, 2019 - 21:25 MST
Update
CallTower is continuing to communicate with Perficient as they work directly with Microsoft to resolve the current global issue with their platform. CallTower executive management continues to escalate with Perficient. An additional update on progress will be provided by 9:00 AM MT, unless a status change is provided before that time.

The current work-around is still effective in granting users call functionality independent from the Clarity Dashboard. Enable the option for “Dashboard without Skype” on the Agent Profile in the Clarity Connect Admin Portal. Users will need to manually login to the SfB and answer calls from the SfB client. Agents should still use the dashboard for call controls.

If you are experiencing this issue and need assistance enabling the work-around please contact support@calltower.com or call 800-347-5444.
Posted 16 days ago. Feb 01, 2019 - 21:04 MST
Identified
Perficient, the developer of Clarity Connect, has acknowledged the issue and dedicating all resources to identifying the root-cause. Preliminary investigation has determined there was a change with Microsoft’s WebSDK that is impacting the Skype for Business components of the Clarity Connect platform. Perficient is working with Microsoft to correct the issue. CallTower executive management will continue to escalate with Perficient. An additional update will be posted as it becomes available from Perficient.

The current work-around is still effective in granting users call functionality independent from the Clarity Dashboard. Enable the option for “Dashboard without Skype” on the Agent Profile in the Clarity Connect Admin Portal. Users will need to manually login to the SfB and answer calls from the SfB client. Agents should still use the dashboard for call controls.

If you are experiencing this issue and need assistance enabling the work-around please contact support@calltower.com or call 800-347-5444.
Posted 16 days ago. Feb 01, 2019 - 17:35 MST
Investigating
CallTower Support has identified an issue with Skype for Business’ (SfB) interaction with the Clarity Dashboard. This is presenting as an error in the Clarity Dashboard indicating "Oops! Bootstrap failed. Skype integration could not be initialized. Please reload me. If this problem persists, please contact your sys admin.” Clarity Connect’s developer, Perficient, has identified this a larger platform issue. CallTower Engineering is engaged and investigating the issue and will provide update as it becomes available.

Users who are already logged in should have no issues with current service so long as they do not reload or refresh their dashboard interface. A current work-around is to enable the option for “Dashboard without Skype” on the Agent Profile in the Clarity Connect Admin Portal. Users will need to manually login to the SfB and answer calls from the SfB client. Agents can utilize the dashboard independently; however call handling will remain on the SfB client.

If you are experiencing this issue please contact support@calltower.com or call 800-347-5444.
Posted 16 days ago. Feb 01, 2019 - 16:43 MST
This incident affected: Contact Center (Clarity Connect).