Skype for Business Outbound Call Failures
Incident Report for CallTower
Resolved
CallTower has continued to monitor the Skype for Business platform and can confirm all services have stabilized. Affected customers have also reported the issue to be resolved. At this time CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request.
Posted Mar 29, 2021 - 14:45 MDT
Monitoring
CallTower is seeing services normalize and customers are reporting outbound calls are now working. CallTower Engineers are continuing to monitor the situation to ensure the issue has been resolved.

*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Mar 29, 2021 - 14:21 MDT
Investigating
CallTower is currently investigating reports of outbound call failures for customers on Skype for Business (SfB). Call examples have been escalated to our engineering team for review.


*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Mar 29, 2021 - 13:46 MDT
This incident affected: Skype for Business (Skype for Business - Voice).