Intermittent Teams Direct Routing Call Issues
Incident Report for CallTower
Resolved
After a period of continued monitoring, CallTower can confirm that the software update has been successful, and the issue is no longer present. CallTower Engineers have determined that services have remained fully functional after remediation steps taken overnight. At this time CallTower will be closing this master case and all associated cases. Within three business days, an Official Root Cause Analysis (RCA) or a Preliminary RCA will be available and provided to customers upon request.
Posted Sep 03, 2021 - 15:10 MDT
Update
CallTower has continued to work with the hardware vendor and through those efforts a software issue was identified. Engineers worked with the vendor to update the software pursuant to vendor specifications. CallTower’s monitoring systems have shown that services continue to be stable post software update. CallTower Engineers will continue to monitor the situation closely and further updates will be provided as necessary.

*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com.
Posted Sep 03, 2021 - 08:15 MDT
Update
CallTower has worked with the hardware vendor to implement additional steps to help mitigate the issue. Monitoring efforts are no longer showing any of the previous symptoms and services have once again normalized. CallTower Engineers will continue to monitor the situation throughout the evening and further updates will be provided as necessary.

*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com.
Posted Sep 02, 2021 - 17:16 MDT
Update
CallTower’s monitoring efforts are showing that the issue still persists for some customers. CallTower is continuing to work with the hardware vendor to further analyze and identify the root cause.

*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Sep 02, 2021 - 16:26 MDT
Update
CallTower continues to monitor services closely to ensure full resolution. Review of active traffic indicates services have normalized for all customers. CallTower has engaged the hardware vendor to identify the root cause of the issue.

*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Sep 02, 2021 - 15:37 MDT
Monitoring
CallTower has removed the impacted hardware from call routing and is closely monitoring traffic. Calls are successfully traversing the geo-redundant route. Review of traffic patterns indicate services have normalized for customers.

*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Sep 02, 2021 - 14:56 MDT
Identified
CallTower engineers have identified an intermittent issue with a piece of hardware in our ATL data center. Our engineering teams are working to remove the hardware from call routing and force traffic through geo-redundant resources.

*CallTower has opened a master case for this issue as it is affecting more than one CallTower customer. This issue may or may not directly affect your services. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise.
Posted Sep 02, 2021 - 14:23 MDT
Investigating
CallTower is investigating reports of intermittent inbound and outbound calling issues for customers on Microsoft Teams Direct Routing. This issue has been escalated to our engineering teams for review.

*CallTower has opened a master case to investigate this issue as it has been reported by more than one CallTower customer. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Sep 02, 2021 - 13:50 MDT
This incident affected: Microsoft (Microsoft Teams - Direct Routing).