Intermedia CCA Connection issue
Incident Report for CallTower
Resolved
Intermedia has reported this issue has been resolved and CallTower has confirmed resolution with impacted customers. If you are still having issues please report the issue to support@calltower.com.
Posted Jun 16, 2022 - 10:06 MDT
Investigating
CallTower has opened a master case to investigate an issue with Intermedia CCA connection as it has been reported by more than one CallTower customer. Calltower has opened with Intermedia and are currently investigating the issue. This issue may or may not directly affect your services and is currently under investigation. If you are affected, please report the issue to support@calltower.com. CallTower intends to post updates on status.calltower.com approximately every 30 minutes, unless identified otherwise. This issue is being investigated as a top priority.
Posted Jun 16, 2022 - 09:19 MDT
This incident affected: Contact Center (Intermedia).